import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Apple2\\b.*)$";
final String string = "Apple1:Banana1:Pear1\n"
+ "Apple2:Banana2:Pear2\n"
+ "Apple3:Banana3:Pear3\n"
+ "Apple22:Apple24:Pear2\n"
+ "Apple2s:Apple24:Pear2\n"
+ "Apple22:Apple2:Pear2\n"
+ "Apple22:Apple2:Pear2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}