# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(Apple2\b.*)$"
test_str = ("Apple1:Banana1:Pear1\n"
"Apple2:Banana2:Pear2\n"
"Apple3:Banana3:Pear3\n"
"Apple22:Apple24:Pear2\n"
"Apple2s:Apple24:Pear2\n"
"Apple22:Apple2:Pear2\n"
"Apple22:Apple2:Pear2")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.