#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([-\s_])"
Local $sString = "filename-1055" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)