use strict;
my $str = 'filename-1055
';
my $regex = qr/([-\s_])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";