$re = '/([-\s_])/';
$str = 'filename-1055
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;