const regex = /([-\s_])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([-\\s_])', '')
const str = `filename-1055
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);