using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cat(?:(?!bird|cat).)*dog(?:(?!dog|bird).)*bird";
string input = @"cat abcd
abc <dog abc
</bird>
cat abcd
abc </bird> abc
<dog
catabcd
abc <dog abc
</bird>
cat abcd
</bird>
<dog
<dog
cat
</bird>
match: cat dog bird
match, so we have: cat dog bird, cat dog dog bird, and cat dog cat bird should all
not match first cat: cat cat dog bird
not match second dog: cat dog dog bird
not match lsat bird: cat dog bird bird";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}