$re = '`cat(?:(?!bird|cat).)*dog(?:(?!dog|bird).)*bird`sm';
$str = 'cat abcd
abc <dog abc
</bird>
cat abcd
abc </bird> abc
<dog
catabcd
abc <dog abc
</bird>
cat abcd
</bird>
<dog
<dog
cat
</bird>
match: cat dog bird
match, so we have: cat dog bird, cat dog dog bird, and cat dog cat bird should all
not match first cat: cat cat dog bird
not match second dog: cat dog dog bird
not match lsat bird: cat dog bird bird';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);