use strict;
my $str = 'cat abcd
abc <dog abc
</bird>
cat abcd
abc </bird> abc
<dog
catabcd
abc <dog abc
</bird>
cat abcd
</bird>
<dog
<dog
cat
</bird>
match: cat dog bird
match, so we have: cat dog bird, cat dog dog bird, and cat dog cat bird should all
not match first cat: cat cat dog bird
not match second dog: cat dog dog bird
not match lsat bird: cat dog bird bird';
my $regex = qr`cat(?:(?!bird|cat).)*dog(?:(?!dog|bird).)*bird`smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}