import Foundation
let pattern = #"cat(?:(?!bird|cat).)*dog(?:(?!dog|bird).)*bird"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
cat abcd
abc <dog abc
</bird>
cat abcd
abc </bird> abc
<dog
catabcd
abc <dog abc
</bird>
cat abcd
</bird>
<dog
<dog
cat
</bird>
match: cat dog bird
match, so we have: cat dog bird, cat dog dog bird, and cat dog cat bird should all
not match first cat: cat cat dog bird
not match second dog: cat dog dog bird
not match lsat bird: cat dog bird bird
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)