using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent).*(?!\1)(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent)";
string input = @"red foo orange
red foo red";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}