const regex = /(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent).*(?!\1)(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent).*(?!\\1)(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent)', 'gm')
const str = `red foo orange
red foo red`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}