re = /(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent).*(?!\1)(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent)/m
str = 'red foo orange
red foo red'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end