import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent).*(?!\\1)(red|orange|yellow|green|cyan|blue|magenta|white|gray|black|transparent)";
final String string = "red foo orange\n"
+ "red foo red";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}