#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)href="(.+)(?<!\.css|\.js)""
Local $sString = "href="http://testurl.com/abc/11111.html"" & @CRLF & _
"href="http://testurl.com/abc/22222.aspx"" & @CRLF & _
"href="http://testurl.com/abc/33333.php"" & @CRLF & _
"href="http://testurl.com/abc/44444.js"" & @CRLF & _
"href="http://testurl.com/abc/55555.css"" & @CRLF & _
"href="http://testurl.com/abc/66666.js"" & @CRLF & _
"href="http://testurl.com/abc/77777.html""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")