re = /href="(.+)(?<!\.css|\.js)"/m
str = 'href="http://testurl.com/abc/11111.html"
href="http://testurl.com/abc/22222.aspx"
href="http://testurl.com/abc/33333.php"
href="http://testurl.com/abc/44444.js"
href="http://testurl.com/abc/55555.css"
href="http://testurl.com/abc/66666.js"
href="http://testurl.com/abc/77777.html"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end