import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"(.+)(?<!\\.css|\\.js)\"";
final String string = "href=\"http://testurl.com/abc/11111.html\"\n"
+ "href=\"http://testurl.com/abc/22222.aspx\"\n"
+ "href=\"http://testurl.com/abc/33333.php\"\n"
+ "href=\"http://testurl.com/abc/44444.js\"\n"
+ "href=\"http://testurl.com/abc/55555.css\"\n"
+ "href=\"http://testurl.com/abc/66666.js\"\n"
+ "href=\"http://testurl.com/abc/77777.html\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}