$re = '/href="(.+)(?<!\.css|\.js)"/m';
$str = 'href="http://testurl.com/abc/11111.html"
href="http://testurl.com/abc/22222.aspx"
href="http://testurl.com/abc/33333.php"
href="http://testurl.com/abc/44444.js"
href="http://testurl.com/abc/55555.css"
href="http://testurl.com/abc/66666.js"
href="http://testurl.com/abc/77777.html"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);