use strict;
my $str = 'CREATE TABLE abcdeg.table_v1 (
"id" text,
"obj" text,
"version" bigint,
output text,
server text,
PRIMARY KEY ("id", "obj", "version")
) WITH CLUSTERING ORDER BY ("id" ASC, "version" DESC)
AND bloom_filter_fp_chance = 0.1
AND comment = \'\'
AND default_time_to_live = 0
AND gc_grace_seconds = 864000
AND max_index_interval = 2048
AND min_index_interval = 128
AND read_repair_chance = 0.0
AND speculative_retry = \'99.0PERCENTILE\';
CREATE TABLE abcdeg.result_v1 (
"id" text,
"obj" text,
time int,
PRIMARY KEY (("id", "obj"))
) WITH bloom_filter_fp_chance = 0.1
AND comment = \'\'
AND default_time_to_live = 0
AND gc_grace_seconds = 864000
AND max_index_interval = 2048
AND speculative_retry = \'99.0PERCENTILE\';';
my $regex = qr/CREATE\s+TABLE[^.]*\.(\S*)\s*\((.*?)PRIMARY KEY \(?\(([^)]*)\)\)?\s*\)\s*(?:WITH CLUSTERING ORDER BY \(([^)]*)\))?/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}