# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"CREATE\s+TABLE[^.]*\.(\S*)\s*\((.*?)PRIMARY KEY \(?\(([^)]*)\)\)?\s*\)\s*(?:WITH CLUSTERING ORDER BY \(([^)]*)\))?"
test_str = ("CREATE TABLE abcdeg.table_v1 (\n"
" \"id\" text,\n"
" \"obj\" text,\n"
" \"version\" bigint,\n"
" output text,\n"
" server text,\n"
" PRIMARY KEY (\"id\", \"obj\", \"version\")\n"
") WITH CLUSTERING ORDER BY (\"id\" ASC, \"version\" DESC)\n"
" AND bloom_filter_fp_chance = 0.1\n"
" AND comment = ''\n"
" AND default_time_to_live = 0\n"
" AND gc_grace_seconds = 864000\n"
" AND max_index_interval = 2048\n"
" AND min_index_interval = 128\n"
" AND read_repair_chance = 0.0\n"
" AND speculative_retry = '99.0PERCENTILE';\n\n"
"CREATE TABLE abcdeg.result_v1 (\n"
" \"id\" text,\n"
" \"obj\" text,\n"
" time int,\n"
" PRIMARY KEY ((\"id\", \"obj\"))\n"
") WITH bloom_filter_fp_chance = 0.1\n"
" AND comment = ''\n"
" AND default_time_to_live = 0\n"
" AND gc_grace_seconds = 864000\n"
" AND max_index_interval = 2048\n"
" AND speculative_retry = '99.0PERCENTILE';")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.