$re = '/CREATE\s+TABLE[^.]*\.(\S*)\s*\((.*?)PRIMARY KEY \(?\(([^)]*)\)\)?\s*\)\s*(?:WITH CLUSTERING ORDER BY \(([^)]*)\))?/s';
$str = 'CREATE TABLE abcdeg.table_v1 (
"id" text,
"obj" text,
"version" bigint,
output text,
server text,
PRIMARY KEY ("id", "obj", "version")
) WITH CLUSTERING ORDER BY ("id" ASC, "version" DESC)
AND bloom_filter_fp_chance = 0.1
AND comment = \'\'
AND default_time_to_live = 0
AND gc_grace_seconds = 864000
AND max_index_interval = 2048
AND min_index_interval = 128
AND read_repair_chance = 0.0
AND speculative_retry = \'99.0PERCENTILE\';
CREATE TABLE abcdeg.result_v1 (
"id" text,
"obj" text,
time int,
PRIMARY KEY (("id", "obj"))
) WITH bloom_filter_fp_chance = 0.1
AND comment = \'\'
AND default_time_to_live = 0
AND gc_grace_seconds = 864000
AND max_index_interval = 2048
AND speculative_retry = \'99.0PERCENTILE\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);