// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)CREATE\s+TABLE[^.]*\.(\S*)\s*\((.*?)PRIMARY KEY \(?\(([^)]*)\)\)?\s*\)\s*(?:WITH CLUSTERING ORDER BY \(([^)]*)\))?").unwrap();
let string = "CREATE TABLE abcdeg.table_v1 (
\"id\" text,
\"obj\" text,
\"version\" bigint,
output text,
server text,
PRIMARY KEY (\"id\", \"obj\", \"version\")
) WITH CLUSTERING ORDER BY (\"id\" ASC, \"version\" DESC)
AND bloom_filter_fp_chance = 0.1
AND comment = ''
AND default_time_to_live = 0
AND gc_grace_seconds = 864000
AND max_index_interval = 2048
AND min_index_interval = 128
AND read_repair_chance = 0.0
AND speculative_retry = '99.0PERCENTILE';
CREATE TABLE abcdeg.result_v1 (
\"id\" text,
\"obj\" text,
time int,
PRIMARY KEY ((\"id\", \"obj\"))
) WITH bloom_filter_fp_chance = 0.1
AND comment = ''
AND default_time_to_live = 0
AND gc_grace_seconds = 864000
AND max_index_interval = 2048
AND speculative_retry = '99.0PERCENTILE';";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}