# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:max|min)\s\(\s*\d+(?:\s*,\s*\d+)*\s*\))|(?:,\d+)+/$1/gm;t' <<< "max ( 100,200,30,4 )
min ( 10,23,111 )
min ( 10,20 )
10,2,34 + 4"