use strict;
my $str = 'max ( 100,200,30,4 )
min ( 10,23,111 )
min ( 10,20 )
10,2,34 + 4';
my $regex = qr/((?:max|min)\s\(\s*\d+(?:\s*,\s*\d+)*\s*\))|(?:,\d+)+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";