#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:max|min)\s\(\s*\d+(?:\s*,\s*\d+)*\s*\))|(?:,\d+)+"
Local $sString = "max ( 100,200,30,4 )" & @CRLF & _
"min ( 10,23,111 )" & @CRLF & _
"min ( 10,20 )" & @CRLF & _
"10,2,34 + 4"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)