$re = '/((?:max|min)\s\(\s*\d+(?:\s*,\s*\d+)*\s*\))|(?:,\d+)+/m';
$str = 'max ( 100,200,30,4 )
min ( 10,23,111 )
min ( 10,20 )
10,2,34 + 4';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;