# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<p>((?!<\\/p>).)*?(TEXT).*?<\\/p>//g;t' <<< "<p>1 bla bla <em>bla</em> bla bla</p><p>2 bla bla <em>bla</em> bla TEXT bla</p><p>3 bla bla <em>bla</em> bla bla</p><p>4 bla bla <em>bla</em> bla TEXT bla</p><p>5 bla bla <em>bla</em> bla bla</p>"