const regex = /<p>((?!<\/p>).)*?(TEXT).*?<\/p>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>((?!<\\\/p>).)*?(TEXT).*?<\\\/p>', 'g')
const str = `<p>1 bla bla <em>bla</em> bla bla</p><p>2 bla bla <em>bla</em> bla TEXT bla</p><p>3 bla bla <em>bla</em> bla bla</p><p>4 bla bla <em>bla</em> bla TEXT bla</p><p>5 bla bla <em>bla</em> bla bla</p>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);