using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>((?!<\/p>).)*?(TEXT).*?<\/p>";
string substitution = @"";
string input = @"<p>1 bla bla <em>bla</em> bla bla</p><p>2 bla bla <em>bla</em> bla TEXT bla</p><p>3 bla bla <em>bla</em> bla bla</p><p>4 bla bla <em>bla</em> bla TEXT bla</p><p>5 bla bla <em>bla</em> bla bla</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}