re = /<p>((?!<\/p>).)*?(TEXT).*?<\/p>/
str = '<p>1 bla bla <em>bla</em> bla bla</p><p>2 bla bla <em>bla</em> bla TEXT bla</p><p>3 bla bla <em>bla</em> bla bla</p><p>4 bla bla <em>bla</em> bla TEXT bla</p><p>5 bla bla <em>bla</em> bla bla</p>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result