#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^;,\n]*)(;.*\1=|;.*;|;)([^;,=\n]+)(,.*|;.*)?$"
Local $sString = "/foo;/bar=http_2xx_put,/foo=http_2xx_post;http_2xx" & @CRLF & _
"/foo;/foo=http_2xx_post,/bar=http_2xx_put;http_2xx" & @CRLF & _
"/baz;/foo=http_2xx_post,/bar=http_2xx_put;http_2xx" & @CRLF & _
"/baz;;http_2xx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")