using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^;,\n]*)(;.*\1=|;.*;|;)([^;,=\n]+)(,.*|;.*)?$";
string input = @"/foo;/bar=http_2xx_put,/foo=http_2xx_post;http_2xx
/foo;/foo=http_2xx_post,/bar=http_2xx_put;http_2xx
/baz;/foo=http_2xx_post,/bar=http_2xx_put;http_2xx
/baz;;http_2xx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}