$re = '/^([^;,\n]*)(;.*\1=|;.*;|;)([^;,=\n]+)(,.*|;.*)?$/m';
$str = '/foo;/bar=http_2xx_put,/foo=http_2xx_post;http_2xx
/foo;/foo=http_2xx_post,/bar=http_2xx_put;http_2xx
/baz;/foo=http_2xx_post,/bar=http_2xx_put;http_2xx
/baz;;http_2xx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);