const regex = /^([^;,\n]*)(;.*\1=|;.*;|;)([^;,=\n]+)(,.*|;.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^;,\\n]*)(;.*\\1=|;.*;|;)([^;,=\\n]+)(,.*|;.*)?$', 'gm')
const str = `/foo;/bar=http_2xx_put,/foo=http_2xx_post;http_2xx
/foo;/foo=http_2xx_post,/bar=http_2xx_put;http_2xx
/baz;/foo=http_2xx_post,/bar=http_2xx_put;http_2xx
/baz;;http_2xx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}