package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:tell me|g(?:et|ive me)|what(?:\s+i|')s)(?:\s+the)?\s+number)`)
var str = `get the number
get number
what is the number
what's the number
tell me the number
give me number`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}