// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:tell me|g(?:et|ive me)|what(?:\s+i|')s)(?:\s+the)?\s+number)").unwrap();
let string = "get the number
get number
what is the number
what's the number
tell me the number
give me number";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}