$re = '/((?:tell me|g(?:et|ive me)|what(?:\s+i|\')s)(?:\s+the)?\s+number)/';
$str = 'get the number
get number
what is the number
what\'s the number
tell me the number
give me number';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);