const regex = /((?:tell me|g(?:et|ive me)|what(?:\s+i|')s)(?:\s+the)?\s+number)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:tell me|g(?:et|ive me)|what(?:\\s+i|\')s)(?:\\s+the)?\\s+number)', 'g')
const str = `get the number
get number
what is the number
what's the number
tell me the number
give me number`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}