using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}$";
string input = @"asdhj89
asd@sad
7879hn
sdddddddddddddd
121312312ajk99@w$&!%*?
https://regex101.com/r/pZdBSB/1/
https://
abc.
`!@.
#$%.
()_.
^&*.
abc.def.ghi.sdf
...............
`!@.#$%.^&*.()_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}