$re = '/^[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}$/m';
$str = 'asdhj89
asd@sad
7879hn
sdddddddddddddd
121312312ajk99@w$&!%*?
https://regex101.com/r/pZdBSB/1/
https://
abc.
`!@.
#$%.
()_.
^&*.
abc.def.ghi.sdf
...............
`!@.#$%.^&*.()_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);