const regex = /^[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w$@$!%*?&#`()\\_^.]{3}\\.[\\w$@$!%*?&#`()\\_^.]{3}\\.[\\w$@$!%*?&#`()\\_^.]{3}\\.[\\w$@$!%*?&#`()\\_^.]{3}$', 'gm')
const str = `asdhj89
asd@sad
7879hn
sdddddddddddddd
121312312ajk99@w\$&!%*?
https://regex101.com/r/pZdBSB/1/
https://
abc.
\`!@.
#\$%.
()_.
^&*.
abc.def.ghi.sdf
...............
\`!@.#\$%.^&*.()_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}