// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}\.[\w$@$!%*?&#`()\_^.]{3}$").unwrap();
let string = "asdhj89
asd@sad
7879hn
sdddddddddddddd
121312312ajk99@w$&!%*?
https://regex101.com/r/pZdBSB/1/
https://
abc.
`!@.
#$%.
()_.
^&*.
abc.def.ghi.sdf
...............
`!@.#$%.^&*.()_";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}