#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=data_value=").*(?=" \/>)"
Local $sString = "<record ObTime="2017-05-10T23:30" data_value="Ocean Park "The Sea WX" WA US" />" & @CRLF & _
"<record ObTime="2017-11-10T23:30" data_value="Some Other "Demo Text" In Here" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")