$re = '/(?<=data_value=").*(?=" \/>)/';
$str = '<record ObTime="2017-05-10T23:30" data_value="Ocean Park "The Sea WX" WA US" />
<record ObTime="2017-11-10T23:30" data_value="Some Other "Demo Text" In Here" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);