using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=data_value="").*(?="" \/>)";
string input = @"<record ObTime=""2017-05-10T23:30"" data_value=""Ocean Park ""The Sea WX"" WA US"" />
<record ObTime=""2017-11-10T23:30"" data_value=""Some Other ""Demo Text"" In Here"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}