import Foundation
let pattern = #"(?<=data_value=").*(?=" \/>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<record ObTime="2017-05-10T23:30" data_value="Ocean Park "The Sea WX" WA US" />
<record ObTime="2017-11-10T23:30" data_value="Some Other "Demo Text" In Here" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)