# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\G(?!^)|\b[a-zA-Z][a-z]*)([A-Z][a-z]*|\d+)/\U\1_\2/g;t' <<< "FfdffDF
firstLine(874),
secondLine(15),
thirdLineOfText87(0x0001);
ThirdLineOfText87(0x0001);"