# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\G(?!^)|\b[a-zA-Z][a-z]*)([A-Z][a-z]*|\d+)"
test_str = ("FfdffDF\n"
"firstLine(874),\n"
"secondLine(15),\n"
"thirdLineOfText87(0x0001);\n"
"ThirdLineOfText87(0x0001);")
subst = "\\U\\1_\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.