#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\G(?!^)|\b[a-zA-Z][a-z]*)([A-Z][a-z]*|\d+)"
Local $sString = "FfdffDF" & @CRLF & _
"firstLine(874)," & @CRLF & _
"secondLine(15)," & @CRLF & _
"thirdLineOfText87(0x0001);" & @CRLF & _
"ThirdLineOfText87(0x0001);"
Local $sSubst = "\U\1_\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)