#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\b(?:soy|almond)\s*(?:milk)?)\bmilk\b"
Local $sString = ""...almondmilk..." = no match" & @CRLF & _
""...almond milk..." = no match" & @CRLF & _
""...almond word(s) milk..." => matched ['milk']" & @CRLF & _
""...almondword(s)milk..." => matched ['milk']" & @CRLF & _
"" & @CRLF & _
""...soymilk..." = no match" & @CRLF & _
""...soy milk..." = no match" & @CRLF & _
""...soy word(s) milk..." => matched ['milk']" & @CRLF & _
""...soyword(s)milk..." => matched ['milk']" & @CRLF & _
"" & @CRLF & _
"is combined with creamy soy and milk. a fruity and refreshing sip of spring," & @CRLF & _
"is combined with creamy milk. a fruity and refreshing sip of spring, " & @CRLF & _
"" & @CRLF & _
""...milk...this is soy milk and regular milk" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")